Usando Lambdas Java 8 no JSE 5, 6 e 7

java-lambda-expressionOuvi gente comentar que gostaria de usar Lambdas do Java 8, mas que ainda não consegue atualizar a versão do projeto para a nova JDK. O projeto RetroLambda oferece suporte retroativo para usar instruções Lambdas nas versões Java 6, 7, 5 e etc. É só colocar a dependência no pom e ser feliz! Existe alguma limitação nas interfaces, mas vale muito a pena!

Você gostaria de aprender a como usar todos os novos recursos do Java 8? Veja nosso curso de JSE M4 – Desenvolvedor Funcional Java 8. Uma ótima semana a todos!

“Quem toma cuidado com o que diz está protegendo a sua própria vida, mas quem fala demais destrói a si mesmo.” Provérbios 13:3